Sunday , December 8 2019
Home / Others / That's why you need to update your iPhone now – Multimedia

That's why you need to update your iPhone now – Multimedia



Researchers at the Darmstadt University of Technology for Safe Mobile Networking have identified a vulnerability in Apple's iOS 12 mobile operating system. As a result, devices such as the iPhone or iPad can simply crash. According to researchers, about half a billion devices are affected.

survey

Apple products, such as the iPhone, are too expensive?

Are these Spy Waste really available from China?


The attack requires a Wi-Fi-compatible laptop and a programmable board that costs around € 22. In addition to iOS, the vulnerability has a major impact on MacOS, tvOS, and watchOS services. Users of mobile Apple devices are therefore recommended by scientists to install the latest updates (iOS 12.1, macOS 10.14.1, tvOS 5.1 and watchOS 5.1). This solves the problem.

Technical background

With devices such as Airplay, Apple devices users can easily mix up with each other. To work, Apple Wireless Direct Link (AWDL) protocols can be used in the background.

But this is where the risks are hidden, as Professor TU Darmstadt's Matthias Hollick explains: "We simply say that they are ringing with Bluetooth LE and the target device activates AWDL." As a second step, Apple's input sends it to the target device, not completely cleared, allowing us to load the device with meaningless input. "The result: The target device and all nearby devices can crash simultaneously.

No security on Android

Although the vulnerability found only applies to Apple devices, researchers say Android users can not weigh themselves. As a new standard for the Wi-Fi Alliance, the so-called neighboring awareness network (NAN), builds on AWDL. Scientists therefore expect similar shortcomings in NAN.

This video shows how iOS devices can crash with Wi-Fi:

Be aware of the today.at newsletter


You may also be interested in

Post now

Read the comment

(Swe)


Source link